Publicado el 2 comentarios

¿Cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?

¿Cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?

La reciente funcionalidad de actualizaciones automáticas en WordPress 3.7 representa una mejora muy importante para mantener la seguridad y productividad de nuestros sitios web, pero también puede ser todo un reto hacerla funcionar :s.

Después de actualizar a la versión 3.7, seguramente muchos de ustedes se emocionaron – al igual que yo, de esta poderosa y nueva característica.. sin embargo, para algunos de nosotros no ha funcionado y se nos ha mostrado el mensaje:

This site is not able to apply these updates automatically. But we’ll email “site@mvkoen.com” when there is a new security release.

A continuación te mostramos ¿cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?


Plugin: Background Update Tester

Plugins: Background Update Tester
Plugin: Background Update Tester

Es aquí donde entra en juego el plugin oficial “Background Update Tester“, el cual ha sido creado por el equipo a cargo de la más reciente versión de WordPress. El objetivo de “Background Update Tester” es ayudar al usuario a diagnosticar los problemas que evitan el funcionamiento de las actualizaciones automáticas.

El procedimiento es muy sencillo:

Paso 1: Instalar el plugin

Instala el plugin vía escritorio de WordPress o mediante FTP:

¿Cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?

Paso 2: Iniciar diagnóstico

Una vez instalado, ve al menú lateral izquierdo “Escritorio” > “Update Tester“:

¿Cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?

A partir de aquí, el plugin iniciará un diagnóstico en automático y te indicará qué condición impide el funcionamiento de las actualizaciones:

¿Cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?
Ejemplo de Background Update Tester en acción, indicando el fallo y su condición

Para este caso, he solucionado el problema actualizando las siguientes constantes directamente en el archivo “wp-config.php“:

Una vez guardados los cambios, esta corrección permitirá que el diagnostico sea exitoso:

Ejemplo de Background Update Tester en acción, indicando el fallo y su condición

Contar con la información de este diagnóstico, permitirá a los usuarios experimentados atender directamente el problema, y para aquellos que se inician con WordPress, tendrán oportunidad de comunicar la información del error y su condición a su desarrollador o administrador.


Comentarios finales

Si bien son muchos sitios que no tendrán ningún problema con esta funcionalidad automática, la integración de este plugin en tu sitio te permitirá identificar y aislar el error, dando respuesta a lo que sin duda se convertirá en una pregunta muy común: ¿cómo saber si las actualizaciones automáticas de WordPress son compatibles con mi sitio?.

Publicado el 3 comentarios

Cómo desactivar las actualizaciones automáticas de WordPress

A partir de WordPress 3.7 en adelante, se incluye un nuevo sistema de actualizaciones automáticas, permitiendo al software actualizarse a una versión que incluya corrección de errores y mejoras (actualización menor), ello sin la intervención directa del usuario.

Ejemplos:

» Las actualizaciones automáticas funcionarán para actualizar de la versión 3.7 a la versión 3.7.1
» Las actualizaciones automáticas NO funcionarán para actualizar desde una versión 3.7.1 a por ejemplo 3.8

Ahora bien, qué sucederá con aquellos usuarios que realizan modificaciones al core del CMS, o aquellos usuarios que prefieren tener el control manual de las actualizaciones???, existe una forma de desactivar esta nueva funcionalidad – es importante tener en cuenta que WordPress al día te ayudará a evitar problemas de seguridad. A continuación te mostramos cómo desactivar las actualizaciones automáticas en WordPress:


Editar el archivo “wp-config.php

Para desactivar todas las actualizaciones automáticas en WordPress deberás copiar y pegar el siguiente código en tu archivo “wp-config.php“:

Una vez que guardes los cambios, WordPress te notificará de la forma tradicional cuando exista una actualización disponible, ofreciéndote el control sobre cada actualización:

Cómo desactivar las actualizaciones automáticas en WordPress 3.7